Перейти к содержимому

Задание 11 ЕГЭ по информатике 2027: объём сообщения и пароли

Задание 11до 1 баллаобъём сообщения и пароли
Раздел
Теоретические основы информатики
Максимальный балл
1 балл
Уровень
повышенный
Что проверяет
Умение подсчитывать информационный объём сообщения
Что нужно сделать
Посчитать информационный объём номеров, паролей или идентификаторов и найти мощность алфавита или объём памяти.
Как записать ответ
только число: целое, без пробелов и единиц измерения
Время
Около 3 минут по обобщённому плану ФИПИ
Элемент кодификатора
2.2
Компьютер
Специальное ПО по плану ФИПИ не нужно: задание решают рассуждением, программа — для проверки
Файл к заданию
Нет — все данные в условии
В 2026 году
Тоже задание 11

Задание 11 ЕГЭ по информатике 2027 года проверяет, по формулировке обобщённого плана ФИПИ, «умение подсчитывать информационный объём сообщения». Файла к заданию нет, специализированное ПО не предусмотрено: все данные есть в условии, ответ — одно целое число.

Сюжеты два. В прямой задаче известны длина сообщения и мощность алфавита, и считают объём в битах или байтах. В обратной известен отведённый объём памяти, а найти нужно мощность алфавита, наибольшее число пользователей или размер дополнительных сведений об одном пользователе.

Тема в 2027 году не менялась: среди планируемых изменений КИМ объём сообщения не назван. Уровень повышенный, около 3 минут по обобщённому плану, 1 балл. Средний процент выполнения в 2026 году — 43,2 %. Ниже — три типа задания с решением и разбор демоверсии.

Тренажёр задания 11

Десять заданий номера 11 из банка тренажёра — с файлами, как на станции КЕГЭ. Решайте в песочнице Python прямо на странице или у себя; ответ проверяется по ключу, после проверки — верный ответ, разбор и решение на Python, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 11 вместе с остальными — в вариантах целиком.

Типы задания 11 с решением

Мощность алфавита по объёму памяти для номеров

Пример условия

На предприятии каждой детали присваивают серийный номер из 92 символов. Для хранения каждого номера отведено одинаковое и минимально возможное целое число байт, символы кодируются одинаковым и минимально возможным целым числом бит. Для хранения 75 213 номеров требуется не менее 2739 Кбайт памяти. Определите минимально возможную мощность алфавита.

1. Переводим объём в байты: 2739 Кбайт = 2739 · 1024 = 2 804 736 байт. 2. На один номер обязано приходиться не меньше ⌈2 804 73675 213⌉ = 38 байт, иначе суммарного объёма не наберётся. 3. Номер из 92 символов при i битах на символ занимает ⌈92 · i8⌉ байт; ищем наименьшее i, при котором это не меньше 38. 4. При i = 3 выходит 35 байт — мало, при i = 4 уже 46 байт — подходит. 5. Минимальная мощность алфавита, которому хватает ровно 4 бита, равна 23 + 1 = 9.

На примере: 9 символов требуют 4 бита, так как 23 < 9 ≤ 24; при 3 битах номер занимал бы 35 байт, и 75 213 номеров не дотянули бы до отведённой памяти.

Решение на Python
length = 92        # символов в серийном номере
count = 75213      # серийных номеров
cap = 2739 * 1024  # байт памяти, требуется не меньше этого

# сколько байт минимум должно приходиться на один номер, чтобы набрать cap
need = -(-cap // count)  # округление вверх

# ищем минимальное число бит на символ, при котором номер занимает не меньше need байт
bits = 1
while (length * bits + 7) // 8 < need:
    bits += 1

print(2 ** (bits - 1) + 1)  # при bits - 1 битах все символы различить уже нельзя

Ответ: 9

Наибольшее число пользователей по объёму памяти

Пример условия

При регистрации в компьютерной системе каждому пользователю выдаётся пароль из 8 символов. Символы берутся из алфавита, содержащего 32 символа, и кодируются одинаковым и минимально возможным числом бит; пароль записывается минимально возможным целым числом байт. Помимо пароля, о каждом пользователе хранят дополнительные сведения объёмом 67 байт. Определите наибольшее количество пользователей, сведения о которых можно сохранить, если для них отведено не более 3018 Кбайт памяти.

1. Считаем биты на символ: 24 < 32 ≤ 25, значит, каждый символ занимает 5 бит. 2. Пароль из 8 символов — это 40 бит, то есть ⌈408⌉ = 5 байт. 3. Запись об одном пользователе — пароль и дополнительные сведения: 5 + 67 = 72 байта. 4. Переводим память в байты: 3018 · 1024 = 3 090 432 байта; делим нацело: 3 090 432 : 72 = 42 922 записи. 5. Остаток 48 байт меньше одной записи, поэтому в ответ не идёт.

На примере: 72 · 42 922 = 3 090 384 ≤ 3 090 432, а 72 · 42 923 = 3 090 456 — уже больше отведённого.

Решение на Python
import math

length = 8           # символов в пароле
alphabet = 32        # символов в алфавите
extra = 67           # байт дополнительных сведений о пользователе
limit = 3018 * 1024  # байт памяти, не больше этого

# сколько бит нужно, чтобы различить все символы алфавита
bits = (alphabet - 1).bit_length()
password = math.ceil(length * bits / 8)  # пароль — целое число байт
record = password + extra                # вся запись о пользователе

print(limit // record)  # сколько целых записей поместится

Ответ: 42922

Байты на дополнительные сведения о пользователе

Пример условия

При регистрации в компьютерной системе каждому пользователю выдаётся пароль из 15 символов. Символы берутся из алфавита, содержащего 6 символов, и кодируются одинаковым и минимально возможным числом бит; пароль записывается минимально возможным целым числом байт. Помимо пароля, о каждом пользователе хранят дополнительные сведения. Для хранения сведений о 2285 пользователях отведено 56 659 байт памяти, при этом запись о каждом пользователе занимает одинаковое целое число байт. Определите наибольшее возможное количество байт на дополнительные сведения об одном пользователе.

1. Биты на символ: 22 < 6 ≤ 23, то есть 3 бита. 2. Пароль из 15 символов — это 45 бит, то есть ⌈458⌉ = 6 байт. 3. Записи одинаковые, поэтому на одну запись приходится не больше ⌊56 6592285⌋ = 24 байта. 4. Дополнительные сведения — остаток записи после пароля: 24 − 6 = 18 байт. 5. Больше нельзя: 2285 · 25 = 57 125 байт, а отведено только 56 659.

На примере: свободный остаток 56 659 − 2285 · 24 = 1819 байт не позволяет добавить по байту каждому пользователю.

Решение на Python
length = 15     # символов в пароле
alphabet = 6    # символов в алфавите
users = 2285    # столько пользователей
cap = 56659     # байт отведено на все записи

# минимальное число бит на символ: 2 ** bits >= alphabet
bits = 1
while 2 ** bits < alphabet:
    bits += 1

password = (length * bits + 7) // 8  # минимальное целое число байт на пароль
record = cap // users                # байт на одну запись, записи одинаковые

print(record - password)

Ответ: 18

Как выполнять задание

  1. Определите направление задачи: дана мощность алфавита или длина — задача прямая, дан объём памяти — обратная.
  2. Переведите объём в байты, помня, что 1 Кбайт = 1024 байта.
  3. Найдите минимальное число бит на символ: наименьшее i, при котором 2i не меньше мощности алфавита.
  4. Округлите объём одного объекта вверх до целого числа байт — объект хранится целым числом байт.
  5. Решите неравенство и обязательно проверьте соседнее значение i: условию должно удовлетворять ровно одно из двух.
  6. Запишите ответ одним целым числом, без пробелов и единиц измерения.

Что нужно знать

  • Формула Хартли. N = 2i: i бит различают N вариантов. Отсюда минимальное число бит на символ алфавита мощности N равно i = ⌈log2N⌉, а наибольшая мощность при i битах — 2i.
  • Объём сообщения. K символов занимают K · i бит, а объект хранится минимальным целым числом байт: ⌈K · i8⌉.
  • Обратная задача. Если на M объектов отведено V байт, на один объект приходится не больше ⌊VM⌋ байт, а бит на символ — не больше ⌊8 · байт на объектK⌋.
  • Единицы. Соглашения демоверсии: «Обозначения Мбайт и Кбайт используются в традиционном для информатики смысле – как обозначения единиц измерения, чьё соотношение с единицей «байт» выражается степенью двойки».

Как оценивается

Проверка автоматическая, по ключу: ответ должен быть записан в форме из условия и полностью совпасть с эталоном. Код и черновики не проверяют — значение имеет только ответ. За верный ответ — 1 балл, частичного балла нет.

Критерии всех заданий экзамена — на странице критериев ЕГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года серийный номер состоит из 157 символов, для хранения 12 450 номеров отведено не более 955 Кбайт, найти нужно максимально возможную мощность алфавита. 955 Кбайт — это 955 · 1024 = 977 920 байт, значит, на один номер приходится не больше ⌊977 92012 450⌋ байт: дробь равна примерно 78,55, поэтому номер занимает не больше 78 байт, откуда 157 · i ≤ 624 и i ≤ 3,97.

Проверим границы: при i = 3 номер занимает ⌈157 · 38⌉ = 59 байт, а 12 450 номеров — 734 550 байт, это меньше 977 920; при i = 4 выходит 79 байт и 983 550 байт — уже больше отведённого. Значит, символы кодируются 3 битами, а мощность алфавита равна 23 = 8 — ключ демоверсии.

Типичные ошибки

Килобайт считают за 1000 байт

Приставки в ЕГЭ двоичные: 955 Кбайт — это 955 · 1024 байт, а не 955 000. Десятичный счёт меняет и число байт на объект, и найденное число бит.

Округляют один раз в самом конце

Сначала объём одного объекта округляют вверх до целого числа байт и только потом умножают на число объектов. Если перемножить биты и разделить один раз в конце, округление выйдет другим.

Объём объекта округляют вниз

Длина объекта — это ⌈K · i8⌉: при 471 бит объект занимает 59 байт, а не 58, потому что 58 байт — это 464 бита, и последние биты не поместятся.

Путают мощность алфавита и число бит

Если по «не менее» нашлось наименьшее i, мощность алфавита равна 2i-1 + 1. Если по «не более» нашлось наибольшее i, ответ равен 2i. Эти два случая легко перепутать.

Проверяют только найденное значение

В задачах на округление ответ держится на границе: убедитесь, что соседнее значение i уже нарушает условие, иначе легко остаться без запаса памяти или взять значение, которому памяти не хватит.

Вопросы и ответы

Сколько баллов даёт задание 11 и сколько на него времени?

1 балл, частичного балла нет. По обобщённому плану ФИПИ на задание отводится около 3 минут, уровень сложности — повышенный. Компьютер и специализированное ПО для него не нужны.

Какие формулы нужны для задания 11?

N = 2i — i бит различают N вариантов; I = K · i — объём сообщения; ⌈K · i8⌉ байт — объём объекта. В обратных задачах добавляются границы: на объект не больше ⌊VM⌋ байт и не больше ⌊8 · байт на объектK⌋ бит на символ.

Что такое мощность алфавита?

Это число разных символов, которыми можно записать сообщение. Символы кодируют минимально возможным числом бит: алфавит мощности 33 требует 6 бит, так как 25 < 33 ≤ 26.

Можно ли решить задание 11 без программы?

Да, расчёт занимает несколько строк на черновике, специализированное ПО для этого задания не предусмотрено. Программа полезна как проверка округления, но на экзамене её набор занимает больше времени, чем счёт руками.

Что изменилось в задании 11 в 2027 году?

Ничего: в планируемых изменениях КИМ 2027 года задание 11 не упомянуто, формулировка темы и уровень те же, что в 2026 году. Сменились соседние номера — 10, 13 и 23.

Другие задания раздела «Теоретические основы информатики»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ЕГЭ по информатике →