Перейти к содержимому

Задание 10 ЕГЭ по информатике 2027: маска подсети и IP-адрес

Задание 10до 1 балламаска подсети и IP-адрес
Раздел
Цифровая грамотность
Максимальный балл
1 балл
Уровень
базовый
Что проверяет
Умение использовать маску подсети
Что нужно сделать
По IP-адресу узла и маске найти адрес сети, число адресов в сети или подходящую маску.
Как записать ответ
только число: целое, без пробелов и единиц измерения
Время
Около 3 минут по обобщённому плану ФИПИ
Элемент кодификатора
1.2
Компьютер
Специальное ПО по плану ФИПИ не нужно: задание решают рассуждением, программа — для проверки
Файл к заданию
Нет — все данные в условии
В 2026 году
Это было задание 13

Задание 10 ЕГЭ по информатике 2027 года проверяет, по формулировке ФИПИ, «умение использовать маску подсети». Это задача про адресацию в сетях TCP/IP: по адресу узла и маске нужно найти адрес сети, посчитать, сколько адресов в сети можно назначить устройствам, или подобрать наибольшую маску для известного адреса сети. Файла к заданию нет и компьютер для него не требуется: все числа есть в условии, а ответ вводится как одно целое число.

Для нумерации 2027 года задание новое: в 2026 году под номером 10 был информационный поиск средствами текстового процессора, а маска подсети стояла под номером 13. В спецификации сказано: «Тематика задания 10 «Информационный поиск средствами текстового процессора» изменена на «Умение использовать маску подсети». Тематика задания 13 «Умение использовать маску подсети» изменена на «Умение анализировать ход исполнения алгоритма».» Уровень задания базовый, по обобщённому плану ФИПИ на него отводят около 3 минут, за верный ответ — 1 балл, частичного балла нет. По итогам 2026 года средний процент выполнения задания с маской подсети (тогда оно шло под номером 13) — 52,0.

Ниже — три типа задания с решением на Python, разбор демоверсии 2027 года и типичные ошибки.

Тренажёр задания 10

Десять заданий номера 10 из банка тренажёра — с файлами, как на станции КЕГЭ. Решайте в песочнице Python прямо на странице или у себя; ответ проверяется по ключу, после проверки — верный ответ, разбор и решение на Python, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 10 вместе с остальными — в вариантах целиком.

Типы задания 10 с решением

Адрес сети по адресу узла и маске

Пример условия

Даны адрес узла 138.206.92.212 и маска 255.255.252.0. Найдите адрес сети. В ответе укажите сумму числовых значений октетов найденного IP-адреса.

1. Разбиваем адрес и маску на октеты: 138, 206, 92, 212 и 255, 255, 252, 0. 2. Применяем поразрядную конъюнкцию к каждой паре октетов: 138 ∧ 255 = 138, 206 ∧ 255 = 206, 92 ∧ 252 = 92, 212 ∧ 0 = 0. 3. Получаем адрес сети 138.206.92.0 и складываем его октеты.

На примере: 252 = 111111002 обнуляет только два младших разряда октета, а у числа 92 = 010111002 эти разряды уже нулевые, поэтому третий октет не изменился. Сумма: 138 + 206 + 92 + 0 = 436.

Решение на Python
# адрес узла и маску храним как одно 32-разрядное число: так видна сама операция
node = (138 << 24) | (206 << 16) | (92 << 8) | 212
mask = (255 << 24) | (255 << 16) | (252 << 8) | 0

network = node & mask  # поразрядная конъюнкция даёт адрес сети

# раскладываем результат обратно на четыре октета и складываем их
total = 0
for shift in (24, 16, 8, 0):
    total += (network >> shift) & 255
print(total)

Ответ: 436

Число адресов, которые можно назначить узлам

Пример условия

Сеть задана IP-адресом одного из входящих в неё узлов 184.168.147.128 и сетевой маской 255.255.254.0. Широковещательным называется адрес, в котором на месте нулей маски стоят единицы; адрес сети и широковещательный адрес не могут быть использованы для адресации сетевых устройств. Сколько различных IP-адресов в этой сети может быть назначено узлам?

1. Считаем нули в маске: 255.255.254.0 — это 23 единицы и 9 нулей, значит номер узла занимает 9 разрядов. 2. Всего адресов в сети 29 = 512. 3. Два адреса заняты — адрес сети и широковещательный, поэтому узлам остаётся 512 − 2 = 510.

На примере: 254 = 111111102, то есть в третьем октете под номер узла уходит один разряд, а в четвёртом — все восемь; вместе 1 + 8 = 9 разрядов.

Решение на Python
import ipaddress

node = ipaddress.IPv4Address('184.168.147.128')
mask = ipaddress.IPv4Address('255.255.254.0')

# модуль ipaddress сам применяет маску и знает размер сети
net = ipaddress.IPv4Network(f'{node}/{mask}', strict=False)

# адрес сети и широковещательный адрес узлам не назначают
print(net.num_addresses - 2)

Ответ: 510

Наибольшее число единиц в маске

Пример условия

Сеть имеет адрес 11.62.48.0, а один из входящих в неё узлов — адрес 11.62.53.78. Определите, какое наибольшее число единиц может содержать двоичная запись маски этой сети.

1. Маска — это идущие подряд с начала единицы, поэтому единица в маске может стоять только там, где разряды адреса сети и адреса узла совпадают: в остальных разрядах конъюнкция дала бы другой адрес сети. 2. Значит, наибольшее число единиц равно длине общего начала (префикса) двух адресов. 3. Сравниваем разряды, начиная со старшего, и останавливаемся на первом различии.

На примере: первые два октета совпадают полностью — это 16 разрядов. Далее 48 = 001100002 и 53 = 001101012: общими остаются пять старших разрядов, шестой у них уже разный (0 и 1). Итого 16 + 5 = 21 единица.

Решение на Python
# адрес сети и адрес узла — как 32-разрядные числа
network = (11 << 24) | (62 << 16) | (48 << 8) | 0
node = (11 << 24) | (62 << 16) | (53 << 8) | 78

# маска сплошная: единица в ней возможна только там, где адреса совпадают
diff = network ^ node  # единицы там, где адреса различаются

# число совпадающих старших разрядов и есть наибольшее число единиц
print(32 - diff.bit_length())

Ответ: 21

Как выполнять задание

  1. Разбейте адрес и маску на октеты и выпишите их столбиком — так видно, что делает каждый октет маски.
  2. Определите, что именно спрашивают: адрес сети, число адресов для узлов или наибольшее число единиц в маске. От этого зависит способ решения.
  3. Для адреса сети переводите в двоичный вид только неполные октеты маски: 255 оставляет октет без изменений, 0 обнуляет его, а 128, 192, 224, 240, 248, 252, 254 сохраняют соответственно 1, 2, 3, 4, 5, 6 или 7 старших разрядов.
  4. Для числа адресов посчитайте нули маски: всего адресов в сети 2n, а узлам доступны 2n − 2, потому что адрес сети и широковещательный адрес устройствам не выдают.
  5. Проверьте себя на коротком примере: для адреса 172.16.5.10 и маски 255.255.0.0 адрес сети — 172.16.0.0, значит два последних октета маски обнуляют всё, что в них стоит.
  6. В ответ впишите одно целое число, без точек, пробелов и подписей: в задании всегда сказано, что считать — сумму октетов, количество адресов или число единиц.

Что нужно знать

  • Адрес и маска. IP-адрес — 32 разряда, записанные четырьмя октетами со значениями от 0 до 255. Маска — это k единиц, за которыми идут 32 − k нулей; короткая запись — /k, например 255.255.252.0 — это /22.
  • Адрес сети. Получается поразрядной конъюнкцией адреса узла и маски: октет маски 255 оставляет октет адреса как есть, октет 0 обнуляет его, а промежуточные значения сохраняют часть старших разрядов.
  • Число адресов. В сети 232 − k адресов; адрес сети (в части узла все нули) и широковещательный адрес (все единицы) сетевым устройствам не назначают, поэтому узлам доступны 232 − k − 2 адресов.
  • Наибольшая маска. Маска сплошная, поэтому её единицы могут стоять только там, где адрес сети и адрес узла совпадают по разрядам: наибольшее число единиц равно длине их общего начала.
  • Проверка. Адрес сети всегда кратен размеру блока: если третий октет маски 252, то третий октет адреса сети делится на 4. Потренироваться можно в демоверсии КЕГЭ 2027 на сайте.

Как оценивается

Проверка автоматическая, по ключу: ответ должен быть записан в форме из условия и полностью совпасть с эталоном. Код и черновики не проверяют — значение имеет только ответ. За верный ответ — 1 балл, частичного балла нет.

Критерии всех заданий экзамена — на странице критериев ЕГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года даны адрес узла 192.168.159.86 и маска 255.255.252.0; нужно найти адрес сети, а в ответ записать сумму его октетов.

Считаем руками. Маска 255 сохраняет октет без изменений, поэтому первые два октета адреса сети — 192 и 168; маска 0 обнуляет четвёртый октет. Остаётся третий: 159 = 100111112, 252 = 111111002, поразрядно 159 ∧ 252 = 100111002 = 156. Адрес сети — 192.168.156.0, сумма октетов 192 + 168 + 156 + 0 = 516; это ключ ФИПИ. Обратите внимание, как маска 252 действует на октет: сохраняются шесть старших разрядов, а два младших обнуляются, поэтому третий октет адреса сети всегда кратен 4.

В условии приведён и образец формы ответа: если бы адрес сети был равен 100.20.3.4, в ответ следовало бы записать 127. Такой пример удобен для самопроверки — и в уме, и в программе.

Типичные ошибки

Конъюнкция заменена дизъюнкцией

Адрес сети получают поразрядным И, а не ИЛИ: 159 ИЛИ 252 даёт 255, и весь октет выходит неверным. Если октет адреса сети не кратен размеру блока из маски, где-то взята не та операция.

Забыли про два занятых адреса

На вопрос, сколько адресов можно назначить узлам, отвечают 2n вместо 2n − 2. Адрес сети и широковещательный адрес устройствам не выдают — в условии это сказано прямо.

Октет маски переведён неверно

252 принимают за 11111000 и обнуляют три младших разряда вместо двух. Октеты маски — только 128, 192, 224, 240, 248, 252, 254 и 255; проверяйте себя по этому списку.

Округление до целых октетов

В задании о наибольшей маске берут ближайшую «круглую» маску 255.255.0.0 или 255.255.255.0, не сравнивая разряды адресов. Считать нужно биты: маска не может содержать единицу там, где адреса различаются.

Ответ записан не в той форме

Вместо суммы октетов в поле ответа вписывают сам адрес сети (192.168.156.0) или число адресов вместо числа единиц. Требуемая форма всегда названа в последней строке условия.

Вопросы и ответы

Что такое маска подсети простыми словами?

Маска показывает, какая часть 32-разрядного адреса — номер сети, а какая — номер узла: k первых разрядов (в маске единицы) относятся к сети, остальные (нули) — к узлу. Запись /22 означает 22 единицы, то есть маску 255.255.252.0.

Какие типы задания 10 встречаются на экзамене?

Три. Найти адрес сети по адресу узла и маске (чаще всего просят сумму октетов), посчитать число адресов, которые можно назначить узлам, и найти наибольшее число единиц в маске по адресу сети и адресу одного из узлов.

Зачем при подсчёте адресов вычитать два?

В каждой сети есть адрес самой сети (в части узла все нули) и широковещательный адрес (все единицы). Их не назначают сетевым устройствам, поэтому узлам доступны 232 − k − 2 адресов.

Можно ли посчитать задание 10 программой на Python?

Можно: модуль ipaddress входит в стандартную библиотеку и умеет находить адрес сети, широковещательный адрес и число адресов. Компьютер для этого задания не требуется, и на экзамене разрешён Windows «Калькулятор».

Что было на месте задания 10 в 2026 году?

В 2026 году под номером 10 стоял информационный поиск средствами текстового процессора, к заданию прилагался файл в формате .odt; маска подсети была заданием 13. В 2027 году тема перешла в задание 10, а под номером 13 теперь анализ хода исполнения алгоритма — тема бывшего задания 23.

Другие задания раздела «Цифровая грамотность»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ЕГЭ по информатике →