Перейти к содержимому

Задание 14 ЕГЭ по информатике 2027: системы счисления

Задание 14до 1 балласистемы счисления
Раздел
Теоретические основы информатики
Максимальный балл
1 балл
Уровень
повышенный
Что проверяет
Знание позиционных систем счисления
Что нужно сделать
Записать значение выражения в системе счисления и посчитать цифры или найти неизвестную цифру либо основание.
Как записать ответ
только число: целое, без пробелов и единиц измерения
Время
Около 3 минут по обобщённому плану ФИПИ
Элемент кодификатора
2.3
Компьютер
Специальное ПО по плану ФИПИ не нужно: задание решают рассуждением, программа — для проверки
Файл к заданию
Нет — все данные в условии
В 2026 году
Тоже задание 14

Задание 14 ЕГЭ по информатике 2027 года проверяет, по формулировке обобщённого плана ФИПИ, «знание позиционных систем счисления». В демоверсии даны три альтернативных примера через «ИЛИ»: найти наименьшую цифру x, при которой значение выражения из 22-ричных операндов делится на 21, и указать частное; подобрать наименьшее основание по делимости; посчитать, сколько цифр записи значения выражения больше 9. Ответы — 276 296 118, 10 и 2029.

Файла нет, специализированное ПО не предусмотрено: данные есть в условии, ответ — одно целое число. Уровень повышенный, около 3 минут, 1 балл. Тематика в 2027 году не менялась: «изменения структуры КИМ отсутствуют». Средний процент выполнения в 2026 году — 45,2 %.

Ниже — три типа задания с решением на Python, разбор первого примера демоверсии и типичные ошибки.

Тренажёр задания 14

Десять заданий номера 14 из банка тренажёра — с файлами, как на станции КЕГЭ. Решайте в песочнице Python прямо на странице или у себя; ответ проверяется по ключу, после проверки — верный ответ, разбор и решение на Python, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 14 вместе с остальными — в вариантах целиком.

Типы задания 14 с решением

Неизвестная цифра в операндах и кратность значения

Пример условия

Операнды записаны в системе счисления с основанием 25: 265810x25 + 22x425 + 45x725, где x — неизвестная цифра. Найдите наименьшее x, при котором значение выражения кратно 14, и укажите в ответе частное от деления на 14.

1. Найдите вес разряда с x в каждом операнде. 2. Значение линейно зависит от цифры: N(x) = N(0) + x · (сумма весов). 3. Перебирайте x по возрастанию до первого, при котором N(x) делится на заданное число. 4. Разделите N(x) на это число — в ответ идёт частное.

На примере: веса разряда с x равны 1, 25 и 25, сумма 51; при x = 0 значение 549 051 886. По модулю 14: 12 + 9x ≡ 0, откуда x = 8, N = 549 052 294, частное 549 052 294 : 14 = 39 218 021.

Решение на Python
DIGITS = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ'
BASE = 25


def to_dec(s):
    """Значение записи s в системе счисления с основанием BASE."""
    n = 0
    for ch in s:
        n = n * BASE + DIGITS.index(ch)
    return n


for value in range(BASE):            # цифра x принимает значения 0…24
    x = DIGITS[value]
    total = (to_dec('265810' + x)
             + to_dec('22' + x + '4')
             + to_dec('45' + x + '7'))
    if total % 14 == 0:
        print(total // 14)           # ответ — частное, а не найденная цифра
        break

Ответ: 39218021

Наименьшее основание по кратности значения

Пример условия

Операнды записаны в системе счисления с основанием b: 530b + 5204b + 119b. Цифра 9 встречается, поэтому b не меньше 10. Найдите наименьшее b, при котором значение выражения кратно 43, и укажите его в ответе.

1. Основание больше каждой цифры в записях, поэтому b не меньше 10. 2. Сумма — многочлен от b с неотрицательными коэффициентами: с ростом b значение растёт, основания перебираем по возрастанию. 3. Для каждого b переведите записи в десятичные числа и проверьте делимость суммы. 4. Первое подходящее основание — ответ.

На примере: при b от 10 до 14 сумма на 43 не делится, при b = 15 получается 1 170 + 17 329 + 249 = 18 748 = 43 · 436. Ответ — 15.

Решение на Python
DIGITS = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ'


def to_dec(s, base):
    """Значение записи s в системе счисления с основанием base."""
    n = 0
    for ch in s:
        n = n * base + DIGITS.index(ch)
    return n


for base in range(10, 37):           # в записях есть цифра 9, значит base >= 10
    total = sum(to_dec(s, base) for s in ('530', '5204', '119'))
    if total % 43 == 0:
        print(base)
        break

Ответ: 15

Цифры записи значения выражения

Пример условия

Значение выражения 5 · 2948 − 3 · 2940 + 2 · 2934 + 8 · 2914 − 8 · 2912 + 6 записали в системе счисления с основанием 29. Сколько цифр этой записи имеют значение больше 9?

1. Слагаемое c · qe даёт цифру c в разряде e; коэффициенты не больше 9 и в ответ не входят. 2. Отрицательную цифру убирают займом из старшего ненулевого разряда: нули на пути становятся цифрой q − 1, а сам разряд — цифрой q − c. 3. Сложите, сколько разрядов затронул каждый заём. 4. Проверьте программой: переведите значение в систему q и посчитайте цифры больше 9.

На примере: заём для 8 · 2912 затрагивает разряды 13 и 12 — 2 разряда; заём для 3 · 2940 — разряды 40–47, это 8 разрядов. Итого 10.

Решение на Python
def digits_in_base(n, base):
    """Цифры записи числа n в системе с основанием base (от младшей к старшей)."""
    result = []
    while n:
        result.append(n % base)
        n //= base
    return result


value = 5 * 29**48 - 3 * 29**40 + 2 * 29**34 + 8 * 29**14 - 8 * 29**12 + 6

print(sum(1 for d in digits_in_base(value, 29) if d > 9))

Ответ: 10

Шаблон кода на Python

Системы счисления

int(строка, основание) переводит запись в десятичное число при основании до 36. Если основание больше или нужна запись числа, пригодится to_base списком цифр.

Python
ALPHA = '0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ'

def to_base(n, base):
    digits = []
    while n > 0:
        digits.append(n % base)
        n //= base
    return digits[::-1] or [0]

# 1) неизвестная цифра x в записях
for v in range(15):
    x = ALPHA[v]
    total = int('9' + x + '7', 15) + int('1' + x + '4', 15)
    if total % 13 == 0:
        print(x, total // 13)
        break

# 2) сколько цифр 4 в пятеричной записи выражения
n = 5 ** 20 + 4 * 5 ** 7 - 3
print(to_base(n, 5).count(4))
Вывод
A 197
6

Шаблоны кода ко всем заданиям

Как выполнять задание

  1. Определите, что неизвестно: цифра, основание или число цифр в записи значения.
  2. Напишите перевод записи в десятичное число; для обратной задачи добавьте перевод числа в запись делением с остатком.
  3. Перебирайте неизвестное по возрастанию: цифру — от 0, основание — от наибольшей цифры плюс один. Найдя подходящее значение, выполните требуемое в условии действие — чаще всего деление, и в ответ идёт частное, а не цифра.
  4. Проверьте программу ручным расчётом на небольшом значении: подстановка должна дать верную делимость и итоговое число.
  5. Впишите одно целое число, без знака системы счисления и единиц измерения.

Что нужно знать

  • Развёрнутая форма. Значение записи (an…a1a0)q равно an·qn + … + a1·q + a0: это превращает выражение в многочлен от основания.
  • Цифры. Допустимы значения от 0 до q − 1; после 9 идут буквы A = 10, B = 11, …, Z = 35.
  • Сумма цифр. По модулю q − 1 число сравнимо с суммой своих цифр: при основании 22 это быстрая проверка делимости на 3.
  • Линейность по цифре. Если x стоит в известных разрядах, N(x) = N(0) + x · (сумма весов этих разрядов).
  • Заём. Отрицательный коэффициент при qe убирают займом из старшего ненулевого разряда: нули на пути становятся цифрой q − 1, а сам разряд — цифрой q − c.
  • Python. int(s, q) переводит строку в число при q от 2 до 36, divmod(n, q) даёт очередную цифру.

Другие системы счисления разобраны на странице задания 5.

Как оценивается

Проверка автоматическая, по ключу: ответ должен быть записан в форме из условия и полностью совпасть с эталоном. Код и черновики не проверяют — значение имеет только ответ. За верный ответ — 1 балл, частичного балла нет.

Критерии всех заданий экзамена — на странице критериев ЕГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года три примера соединены «ИЛИ»; разобран первый: 27x9887622 + 26x5122 + 711x522. Нужны наименьшее x с делимостью значения на 21 и частное.

Цифра x входит в каждый операнд один раз, поэтому значение линейно зависит от её числового значения v. Веса разрядов с x равны 225 = 5 153 632, 222 = 484 и 22, в сумме 5 154 138; при x = 0 значение равно 5 786 756 064. Делимость проверяем по модулю 21 = 3 · 7. Так как 22 ≡ 1 (mod 3), по модулю 3 число сравнимо с суммой цифр: 47 + v + 14 + v + 14 + v = 3 · (25 + v) делится на 3 при любом v. По модулю 7: 5 786 756 064 даёт остаток 5, 5 154 138 — остаток 3, значит 5 + 3v ≡ 0 и v ≡ 3 (mod 7); наименьшее значение — 3.

При x = 3 значение равно 5 802 218 478, частное 5 802 218 478 : 21 = 276 296 118 — ключ ФИПИ. Перебор x от 0 до 21 даёт тот же ответ.

Типичные ошибки

Перебор начинают с единицы

Значение цифры может быть нулём, и наименьший ответ иногда именно 0. Цикл с 1 пропустит его и напечатает большее число.

Перебирают только цифры от 0 до 9

В системе с основанием 22 цифра x принимает значения до 21 и обозначается буквами A…L; перебор из десяти значений до них не доходит.

В ответ пишут найденное x

В условии просят вычислить частное. Код с print(x) напечатает значение найденной цифры, а в ответ требуется записать частное, поэтому ответ будет неверным.

Основание перебирают с 2

Записи с цифрой 9 в системе с основанием меньше 10 не существует, и перевод такой записи даст ошибку. Начинайте перебор с наибольшей цифры плюс один.

Цифры больше 9 ищут среди коэффициентов

Коэффициенты слагаемых не превышают 9 и в ответ не входят: цифры q − c и q − 1 появляются только после заёма.

Вопросы и ответы

Как решать задание 14 ЕГЭ по информатике?

Определите тип: неизвестная цифра, основание или число цифр. Переведите записи в десятичные значения по развёрнутой форме и перебирайте неизвестное по возрастанию; найдя значение, выполните требуемое вычисление — чаще всего деление.

Какой шаблон кода на Python подходит для задания 14?

Функция перевода строки в число по основанию и, при необходимости, обратный перевод делением с остатком. Дальше цикл по значениям неизвестного и проверка остатка; последней строкой — print нужного числа.

Сколько баллов даёт задание 14 и сколько на него времени?

1 балл, частичного балла нет. По обобщённому плану ФИПИ — около 3 минут, уровень повышенный.

Что изменилось в задании 14 в 2027 году?

Ничего: «изменения структуры КИМ отсутствуют», среди изменившихся тем 2027 года задание 14 не названо. Как и в 2026 году, оно проверяет позиционные системы счисления; в демоверсии, как и раньше, три альтернативных примера через «ИЛИ».

Другие задания раздела «Теоретические основы информатики»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ЕГЭ по информатике →