Перейти к содержимому

Задание 15 ЕГЭ по информатике 2027: логические выражения

Задание 15до 1 баллалогические выражения
Раздел
Теоретические основы информатики
Максимальный балл
1 балл
Уровень
повышенный
Что проверяет
Знание основных понятий и законов математической логики
Что нужно сделать
Найти параметр A, при котором логическое выражение с делимостью, отрезками или поразрядной конъюнкцией истинно при любом x.
Как записать ответ
только число: целое, без пробелов и единиц измерения
Время
Около 3 минут по обобщённому плану ФИПИ
Элемент кодификатора
2.7
Компьютер
Специальное ПО по плану ФИПИ не нужно: задание решают рассуждением, программа — для проверки
Файл к заданию
Нет — все данные в условии
В 2026 году
Тоже задание 15

Задание 15 ЕГЭ по информатике 2027 года проверяет, по формулировке обобщённого плана ФИПИ, «знание основных понятий и законов математической логики». В КИМ 2026 года под этим номером стояло то же задание: смена тем 2027 года коснулась только заданий 10, 13 и 23.

Дано логическое выражение с переменной x: в него входят делимость (предикат ДЕЛ(n, m)), принадлежность отрезку или поразрядная конъюнкция. Нужно подобрать целое A, при котором выражение истинно при любом допустимом x. Спрашивают наибольшее или наименьшее A, а в задачах про отрезки — наименьшую возможную длину отрезка A. Файла к заданию нет, специализированное ПО не предусмотрено, ответ — одно целое число.

Уровень повышенный, около 3 минут, верный ответ даёт 1 балл. Средний процент выполнения в 2026 году — 46,5 (в 2025 — 48,1). Ниже — три типа задания с решением на Python, дальше — разбор демоверсии и ошибки.

Тренажёр задания 15

Десять заданий номера 15 из банка тренажёра — с файлами, как на станции КЕГЭ. Решайте в песочнице Python прямо на странице или у себя; ответ проверяется по ключу, после проверки — верный ответ, разбор и решение на Python, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 15 вместе с остальными — в вариантах целиком.

Типы задания 15 с решением

Наибольшее A в выражении с ДЕЛ и отрезком

Пример условия

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m»; на числовой прямой дан отрезок B = [83; 126]. Для какого наибольшего натурального числа A выражение

ДЕЛ(x, A) ∨ ((x ∈ B) → ¬(ДЕЛ(x, 6) ∧ ДЕЛ(x, 15)))

истинно при любом целом положительном значении переменной x?

1. Импликация a → b равносильна ¬a ∨ b: при x вне отрезка B выражение истинно при любом A, поэтому ограничение на A даёт только сам отрезок. 2. Для x из B второе слагаемое ложно, когда x делится и на 6, и на 15; тогда истинным обязано быть первое слагаемое — ДЕЛ(x, A). 3. Значит, A делит каждое число отрезка [83; 126], кратное НОК(6, 15) = 30; наибольшее такое A — их НОД.

На примере: кратны 30 числа 90 и 120, оба лежат в [83; 126]. Их НОД равен 30. Проверка: при A = 60 число 90 на A уже не делится.

Решение на Python
from math import gcd

b1, b2 = 83, 126

# выражение ложно только при x из B, который делится и на 6, и на 15, но не на A;
# значит, A делит все такие x, а наибольшее такое A — их НОД
ans = 0
for x in range(b1, b2 + 1):
    if x % 6 == 0 and x % 15 == 0:
        ans = gcd(ans, x)

print(ans)

Ответ: 30

Наименьшая возможная длина отрезка A

Пример условия

На числовой прямой даны два отрезка: P = [30; 98] и Q = [13; 83]. Укажите наименьшую возможную длину такого отрезка A, что логическое выражение

(x ∈ P) → (((x ∈ Q) ∧ ¬(x ∈ A)) → ¬(x ∈ P))

истинно при любом значении переменной x.

1. Раскрываем внешнюю импликацию, затем внутреннюю: выражение равносильно (x ∉ P) ∨ (x ∉ Q) ∨ (x ∈ A). 2. Дизъюнкция ложна, только если x лежит и в P, и в Q, но не попал в A: значит, A обязано накрыть всё пересечение P и Q. 3. Пересечение — [30; 83], его длина 53; меньшим отрезком обе концевые точки не накрыть.

На примере: x = 30 и x = 83 лежат и в P, и в Q, поэтому обязаны попасть в A. Любой отрезок с обеими точками имеет длину не меньше 53.

Решение на Python
p1, p2 = 30, 98
q1, q2 = 13, 83

# выражение ложно только при x из P и из Q, не попавшем в A:
# отрезок A обязан накрыть всё пересечение P и Q
left = max(p1, q1)
right = min(p2, q2)

print(right - left)

Ответ: 53

Наименьшее A в выражении с поразрядной конъюнкцией

Пример условия

Обозначим через m&n поразрядную конъюнкцию неотрицательных целых чисел m и n, например 14&5 = 11102 & 01012 = 01002 = 4. Для какого наименьшего целого неотрицательного числа A выражение

(x & 12 ≠ 0) → ((x & 56 = 0) → (x & A ≠ 0))

тождественно истинно при любом неотрицательном целом значении переменной x?

1. Раскрываем обе импликации: (x & 12 = 0) ∨ (x & 56 ≠ 0) ∨ (x & A ≠ 0). Ложно выражение только при таком x, у которого есть общий единичный разряд с 12, нет общих разрядов с 56 и нет общих разрядов с A. 2. Достаточно x с одним единичным разрядом: каждый разряд числа 12, которого нет в 56, обязан входить в A. 3. 12 = 11002, 56 = 1110002; разряд 8 = 23 есть в обоих, а разряд 4 = 22 — только в 12.

На примере: при x = 4 имеем x & 12 = 4 ≠ 0 и x & 56 = 0, поэтому разряд 4 должен стоять в A. При x = 8 истинно x & 56 ≠ 0, и разряд 8 в A не нужен.

Решение на Python
p = 12
q = 56

# выражение ложно только при x, у которого есть разряд из p, нет разрядов из q
# и нет общих разрядов с A: значит, A содержит все разряды p, которых нет в q
ans = 0
bit = 1
while bit <= max(p, q):
    if (p & bit) and not (q & bit):
        ans |= bit
    bit <<= 1

print(ans)

Ответ: 4

Шаблон кода на Python

Логическое выражение при любом x

Перебираете A, для каждого проверяете выражение на всех x из достаточно большого диапазона. Подходящие A собираете — ответ наибольшее или наименьшее из них.

Python
def div(n, m):
    return n % m == 0

good = []
for A in range(1, 500):
    if all(div(x, A) or not div(x, 6) or div(x, 9) for x in range(1, 2000)):
        good.append(A)
print(max(good))   # ДЕЛ(x, A) ∨ (ДЕЛ(x, 6) → ДЕЛ(x, 9))
Вывод
6

Шаблоны кода ко всем заданиям

Как выполнять задание

  1. Прочитайте, что именно ищут: наибольшее A, наименьшее A или наименьшую возможную длину отрезка A.
  2. Замените импликацию по формуле a → b = ¬a ∨ b; отрицание над скобкой раскройте по закону де Моргана.
  3. Определите, при каких x выражение может стать ложным: это узкое условие и есть ограничение на A.
  4. Делимость и отрезки разбирайте аналитически, поразрядную конъюнкцию — по разрядам. Если пишете перебор, в задачах с делимостью и отрезками хватает x внутри отрезка, а для поразрядной конъюнкции берите x до 127.
  5. Проверьте ответ подстановкой: при соседнем A выражение должно стать ложным хотя бы при одном x.
  6. В ответ впишите одно целое число, без пробелов и единиц измерения.

Что нужно знать

  • Импликация. a → b = ¬a ∨ b. После замены видно, что дизъюнкция ложна, только если ложны все слагаемые, — множество «плохих» x резко сужается.
  • Законы де Моргана. ¬(a ∧ b) = ¬a ∨ ¬b, ¬(a ∨ b) = ¬a ∧ ¬b.
  • Делимость. ДЕЛ(x, A) — это x % A == 0. «A делит все числа набора» равносильно «A делит их наибольший общий делитель»; «x делится и на 6, и на 15» — «x делится на их НОК».
  • Отрезки. Принадлежность — a <= x <= b, пересечение — [max(левых); min(правых)].
  • Поразрядная конъюнкция. x & A ≠ 0 означает общий единичный разряд у x и A; условие «x & p ≠ 0, а x & q = 0» выделяет разряды, которые есть в p, но отсутствуют в q.

Разбор — в трёх типах ниже; логические законы собраны в разделе теории, рядом — задание 2, а вариант с песочницей есть в демоверсии 2027.

Как оценивается

Проверка автоматическая, по ключу: ответ должен быть записан в форме из условия и полностью совпасть с эталоном. Код и черновики не проверяют — значение имеет только ответ. За верный ответ — 1 балл, частичного балла нет.

Критерии всех заданий экзамена — на странице критериев ЕГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года дан предикат ДЕЛ(n, m) и отрезок B = [70; 90]; нужно наибольшее натуральное A, при котором выражение ДЕЛ(x, A) ∨ ((x ∈ B) → ¬ДЕЛ(x, 22)) истинно при любом целом положительном x.

Заменим импликацию: (x ∈ B) → ¬ДЕЛ(x, 22) равносильно ¬(x ∈ B) ∨ ¬ДЕЛ(x, 22). Тогда всё выражение — ДЕЛ(x, A) ∨ ¬(x ∈ B) ∨ ¬ДЕЛ(x, 22), и ложно оно только когда x не делится на A, лежит в B и делится на 22.

На [70; 90] кратно 22 одно число — 88 = 22 · 4. Значит, A обязано делить 88, а подходит любой делитель 88: 1, 2, 4, 8, 11, 22, 44, 88. Спрашивают наибольшее — это 88. Ответ: 88.

Типичные ошибки

Импликация не раскрыта

Пока в выражении стоит →, понять, при каких x оно ложно, трудно. Замените a → b на ¬a ∨ b: тогда видно, что вся дизъюнкция ложна лишь при одновременной ложности всех слагаемых.

Делимое и делитель перепутаны

Условие требует, чтобы A делило x, то есть x % A == 0, а не наоборот. При перестановке ответ получается другим, и проверка на типовом примере это сразу показывает.

Наибольшее и наименьшее перепутаны

Подходящих A обычно несколько: в демоверсии 2027 подошёл бы любой делитель 88 — 1, 2, 4, 8, 11, 22, 44, 88, но верно только наибольшее. В задачах про отрезки, наоборот, ищут наименьшую длину.

Отрицание над скобкой не раскрыто

В записи ¬(ДЕЛ(x, 6) ∧ ДЕЛ(x, 15)) отрицание относится ко всей конъюнкции. По закону де Моргана это ¬ДЕЛ(x, 6) ∨ ¬ДЕЛ(x, 15) — «x не делится на 6 или не делится на 15». Прочтение «не делится ни на 6, ни на 15» даёт другое требование к A.

Перебор x на слишком узком диапазоне

В поразрядных задачах x принимает любые неотрицательные значения, но достаточно взять x, покрывающие все разряды чисел из условия: для 12 и 56 хватает x до 63, с запасом — до 127.

Вопросы и ответы

Как решать задание 15 ЕГЭ по информатике?

Раскройте импликации по формуле a → b = ¬a ∨ b, посмотрите, при каких x выражение может стать ложным, и переведите это в требование к A. Делимость и отрезки разбирают аналитически, поразрядную конъюнкцию — по разрядам.

Есть ли шаблон решения задания 15 на Python?

Есть короткая заготовка: перебрать A и для каждого проверить выражение на всех x. В записи пригодятся x % A == 0 для ДЕЛ(x, A) и a <= x <= b для отрезка. Такой перебор служит проверкой ответа, а не основным способом: диапазоны A и x нужно брать с запасом.

Нужна ли программа для задания 15?

По обобщённому плану ФИПИ специализированное ПО не требуется: ответ вписывают вручную, на задание отводится около 3 минут. Программа полезна как проверка — короткий перебор по A и x подтверждает ответ.

Что изменилось в задании 15 в 2027 году?

Ничего: в спецификации сказано «Изменения структуры КИМ отсутствуют», а среди сменивших тему заданий названы только 10, 13 и 23. Уровень, время и балл у задания 15 те же.

Другие задания раздела «Теоретические основы информатики»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ЕГЭ по информатике →