Перейти к содержимому

Задание 8 ЕГЭ по информатике 2027: слова и комбинаторика

Задание 8до 1 балласлова и комбинаторика
Раздел
Теоретические основы информатики
Максимальный балл
1 балл
Уровень
базовый
Что проверяет
Знание основных понятий и методов, используемых при измерении количества информации
Что нужно сделать
Найти номер слова в алфавитном списке или посчитать, сколько слов или чисел удовлетворяют условиям.
Как записать ответ
только число: целое, без пробелов и единиц измерения
Время
Около 4 минут по обобщённому плану ФИПИ
Элемент кодификатора
2.2
Компьютер
Специальное ПО по плану ФИПИ не нужно: задание решают рассуждением, программа — для проверки
Файл к заданию
Нет — все данные в условии
В 2026 году
Тоже задание 8

Задание 8 ЕГЭ по информатике 2027 года, по формулировке обобщённого плана ФИПИ, проверяет «Знание основных понятий и методов, используемых при измерении количества информации». На практике это перебор: дан алфавит или система счисления, и нужно найти номер слова в алфавитном списке либо посчитать, сколько слов или чисел подходят под условия.

Уровень базовый, файла нет, специализированное ПО не требуется, ответ — одно целое число, за верный ответ 1 балл, около 4 минут по плану. Изменений в 2027 году нет: «Изменения структуры КИМ отсутствуют», среди заданий со сменой тематики 8 не названо. Средний процент выполнения — 54,9 в 2026 году и 47,3 в 2025; по методическим рекомендациям ФИПИ «Наибольшее затруднение у группы 2 участников экзамена среди заданий базового уровня сложности вызвали задания 8 и 9».

Ниже — три типа задания с разбором и решением на Python, разбор демоверсии 2027 и типичные ошибки. Программа нужна не всегда: короткие задачи быстрее считать формулой.

Тренажёр задания 8

Десять заданий номера 8 из банка тренажёра — с файлами, как на станции КЕГЭ. Решайте в песочнице Python прямо на странице или у себя; ответ проверяется по ключу, после проверки — верный ответ, разбор и решение на Python, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 8 вместе с остальными — в вариантах целиком.

Типы задания 8 с решением

Номер слова в алфавитном списке

Пример условия

Все пятибуквенные слова из букв Ю, Б, А, Д, И записаны в алфавитном порядке и пронумерованы. Найдите номер первого слова, которое не начинается с А и содержит хотя бы одну Б. Начало списка: ААААА, ААААБ, ААААД, ААААИ, ААААЮ, ……

1. Буквы по алфавиту: А, Б, Д, И, Ю — цифры системы с основанием 5, слово — пятизначная запись числа. 2. Номер = значение кода + 1, поэтому ААААА стоит под номером 1. 3. Берём первое слово, где первая буква не А, а Б встречается хотя бы раз.

На примере: слова с первой буквой А занимают номера 1…54 = 625, следующее слово БАААА имеет номер 626 и содержит Б. Ответ — 626.

Решение на Python
from itertools import product

letters = sorted('ЮБАДИ')  # порядок в списке — алфавитный: А, Б, Д, И, Ю
for number, word in enumerate(product(letters, repeat=5), start=1):
    if word[0] != 'А' and 'Б' in word:  # первое подходящее слово
        print(number)
        break

Ответ: 626

Число слов с условиями

Пример условия

Петя составляет пятибуквенные слова из букв слова ТУМАН, каждую букву можно использовать сколько угодно раз. Сколько слов получится, если слово не начинается с гласной и две одинаковые буквы не стоят рядом?

1. Первая буква — не гласная: А и У отпадают, остаются три согласные. 2. Каждая следующая буква — любая из пяти, кроме предыдущей, то есть 4 варианта. 3. Выборы независимы, поэтому по правилу произведения слов 3 · 44 = 768. 4. При большем числе условий считают динамикой: хранят число слов каждой длины по последней букве и достраивают до длины 5.

На примере: ТМТМТ подходит, ТТМТМ — нет. Полный перебор даёт 768.

Решение на Python
letters = 'ТМНУА'   # все буквы слова ТУМАН
soglasnye = 'ТМН'  # слово не начинается с гласной

# dp[c] — сколько слов текущей длины оканчивается на букву c
dp = {c: 1 for c in soglasnye}
for _ in range(4):                 # достраиваем слова до длины 5
    new = {c: 0 for c in letters}
    for prev in dp:
        for c in letters:
            if c != prev:          # две одинаковые буквы рядом запрещены
                new[c] += dp[prev]
    dp = new
print(sum(dp.values()))

Ответ: 768

Числа в системе счисления с условиями

Пример условия

Определите количество четырёхзначных чисел, записанных в девятеричной системе счисления, в записи которых ровно одна цифра 0, а последняя цифра чётная.

1. Запись — набор из четырёх цифр 0…8, первая не ноль. 2. Считаем по месту нуля. Ноль последний: первые три цифры любые, кроме нуля, — 83 = 512 вариантов, чётность выполнена. 3. Ноль на втором или третьем месте: два случая по 8 · 8 вариантов, последняя цифра чётная и не ноль — это 2, 4, 6, 8, то есть 4 варианта; итого 2 · 8 · 8 · 4 = 512. 4. Ноль первым быть не может.

На примере: 512 + 512 = 1024; перебор подтверждает.

Решение на Python
from itertools import product

count = 0
for d1 in range(1, 9):                 # первая цифра не ноль
    for d2, d3 in product(range(9), repeat=2):
        for d4 in (0, 2, 4, 6, 8):     # последняя цифра чётная
            if (d1, d2, d3, d4).count(0) == 1:
                count += 1
print(count)

Ответ: 1024

Шаблон кода на Python

Слова из букв: номер в списке и подсчёт

product перебирает слова в алфавитном порядке, если буквы в строке уже отсортированы. Номер слова — счётчик enumerate с единицы.

Python
from itertools import product

letters = sorted('КОРТ')   # алфавитный порядок
count = 0
first = None
for number, w in enumerate(product(letters, repeat=4), start=1):
    word = ''.join(w)
    if word[0] != 'Р' and word.count('О') == 1:
        count += 1
        if first is None:
            first = number
print(count, first)
Вывод
81 2

Шаблоны кода ко всем заданиям

Как выполнять задание

  1. Выпишите буквы из условия в алфавитном порядке — это «цифры» системы счисления: первая буква 0, вторая 1 и так далее. Порядок букв в условии почти всегда другой, и по нему список не строится.
  2. Определите, что спрашивают: номер слова или количество слов и чисел. Для номера удобен перебор в порядке списка, для количества — правило произведения.
  3. Помните про сдвиг на единицу: слово из одних нулей стоит первым, номер = код + 1. Сверьте это по началу списка из условия.
  4. Оцените объём перебора: слов длины 5 из шести букв 65 = 7776, четырёхзначных чисел в девятеричной системе 8 · 93. Если вариантов миллионы, перебирайте по позициям.
  5. Ответ вводите одним целым числом, без пробелов и единиц измерения.

Что нужно знать

  • Алфавитный список как система счисления. N букв по алфавиту — цифры 0, …, N − 1; слово длины k — k-значная запись числа; номер = значение + 1.
  • Количество слов. Nk, если буквы повторяются, и n · (n − 1) · … · (n − k + 1), если повторять нельзя.
  • Правило произведения. Условия «ровно одна», «не менее одной» считают по местам: выбрать места и перемножить варианты.
  • Чётность. Номер и код различаются на 1, поэтому их чётность противоположна.
  • Первая цифра числа. Она не ноль, поэтому наборов не Nk, а (N − 1) · Nk − 1; у слова такого ограничения нет.
  • Python. product перебирает слова в порядке списка, если буквы переданы по алфавиту; enumerate(…, start=1) даёт номер.

Как оценивается

Проверка автоматическая, по ключу: ответ должен быть записан в форме из условия и полностью совпасть с эталоном. Код и черновики не проверяют — значение имеет только ответ. За верный ответ — 1 балл, частичного балла нет.

Критерии всех заданий экзамена — на странице критериев ЕГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года слова длины 5 составляют из букв А, К, Ц, Е, Н, Т. По алфавиту они идут так: А, Е, К, Н, Т, Ц — это цифры 0…5 шестеричной системы, а слово — пятиразрядная запись числа; номер слова на 1 больше её значения.

Нужно первое по порядку слово с чётным номером, не начинающееся с А, Е или К и содержащее хотя бы одну Т. Ближайшее разрешённое начало — Н, код такой группы 3 · 64 + r = 3888 + r, где r — код последних четырёх букв. Значение 3888 чётное, а номер на 1 больше, поэтому чётный номер отвечает нечётному r. Перебираем r: 4, 10, 16, 22 дают слова НАААТ, НААЕТ, НААКТ, НААНТ, а 24 — НААТА; все они чётные. Первое нечётное значение с буквой Т — r = 25, запись 00416, слово НААТЕ. Код 3888 + 25 = 3913, номер 3914 — ключ ФИПИ. Программа из первого типа ниже на алфавите демоверсии печатает 3914; файла у задания нет, поэтому ответ проверяется тем же перебором.

Типичные ошибки

Забыли про нумерацию с единицы

ААААА имеет номер 1, хотя её код равен 0. Печать кода даёт ответ на 1 меньше: в демоверсии 3913 вместо 3914. Номер = код + 1.

Буквы перебирают не по алфавиту

Порядок слов задаёт алфавит, а не порядок букв в условии. product('АКЦЕНТ', repeat=5) переберёт слова иначе и даст другой номер; строку букв пишите по алфавиту.

Ищут последнее слово, а останавливаются на первом

При условии «последнее слово с чётным номером» break после первой находки даст неверный ответ: список проходят до конца и запоминают последнее подходящее слово.

Чётность номера принимают за чётность кода

Они противоположны. Если отбирать чётные остатки r, верное слово НААТЕ с r = 25 пропускается.

У числа перебирают записи с ведущим нулём

В четырёхзначном девятеричном числе первая цифра не ноль, поэтому вариантов 8 · 93, а не 94: лишние наборы — это трёхзначные записи.

Вопросы и ответы

Как решать задание 8 ЕГЭ по информатике?

Двумя способами. Формулой: буквы по алфавиту — цифры системы счисления, поэтому количество слов считают по правилу произведения, а номер слова — как значение кода плюс 1. Перебором: product проходит слова в порядке списка, условия проверяет обычный if. Формула быстрее, перебор надёжнее при нескольких условиях.

Можно ли решить задание 8 без программы?

Да, если условий один-два: количество считается по правилу произведения, номер — как значение в системе счисления. Программа нужна при нескольких условиях или длинном слове: перебрать 65 = 7776 слов руками неудобно. Ответ всё равно одно число, ход решения не проверяется.

Сколько баллов даёт задание 8 и сколько на него времени?

1 балл, частичного балла нет. По обобщённому плану ФИПИ на задание отводится около 4 минут, уровень сложности базовый.

Изменилось ли задание 8 в 2027 году?

Нет. В спецификации 2027 года сказано: «Изменения структуры КИМ отсутствуют»; тематику сменили задания 10, 13 и 23. В КИМ 2026 года под номером 8 стояло то же задание, средний процент выполнения — 54,9.

Нужен ли на экзамене модуль itertools?

Нет, вложенные циклы по буквам дают тот же перебор. Но product из стандартной библиотеки Python короче и меньше подвержен опечаткам, а itertools входит в стандартную библиотеку Python, поэтому доступен на станции.

Другие задания раздела «Теоретические основы информатики»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ЕГЭ по информатике →