Перейти к содержимому

Задание 5 ОГЭ по информатике 2027: исполнитель с командами

Задание 5до 1 баллаисполнитель с командами
Раздел
Алгоритмы и программирование · часть 1
Максимальный балл
1 балл
Уровень
базовый
Что проверяет
Анализировать простые алгоритмы для конкретного исполнителя с фиксированным набором команд
Что нужно сделать
Составить программу из команд исполнителя или найти неизвестное число в команде, чтобы из одного числа получить другое.
Как записать ответ
цифры подряд, без пробелов и запятых; ноль в начале — тоже цифра ответа
Время
Около 4 минут по обобщённому плану ФИПИ
Элемент кодификатора
3.4
Где решается
На бланке, без компьютера: ответ — в бланк № 1
Справляются
83,0 % участников по отчётам Кировской и Иркутской областей и Татарстана за 2025 год

Вычислитель, Квадратор, Удвоитель — исполнители пятого задания ОГЭ по информатике меняют имена, но устроены одинаково. На экране стоит число, у исполнителя ровно две команды с номерами 1 и 2: умножить, прибавить, вычесть, возвести в квадрат. Требуется составить программу, которая превращает начальное число в заданное, и уложиться в лимит — обычно не больше пяти команд. В бланк записывают только номера команд подряд, например 21221.

Реже программа уже дана, а найти нужно неизвестное число b в одной из команд. Оба типа решаются на черновике. В демоверсии 2027 года ФИПИ оставил задание в прежнем виде — исполнитель Вычислитель с командами «умножь на 3» и «прибавь 2»; в 2026 году был Квадратор.

Тренажёр задания 5

Десять заданий номера 5 из банка тренажёра. Ответ проверяется по ключу без регистрации: после проверки — верный ответ и разбор, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 5 вместе с остальными — в вариантах целиком.

Типы задания 5 с решением

Программа для Вычислителя: сложение и умножение

Пример условия

У исполнителя Вычислитель две команды, которым присвоены номера:

1. прибавь 3
2. умножь на 2

Составьте алгоритм получения из числа 7 числа 71, содержащий не более 5 команд. В ответе запишите только номера команд. Если таких алгоритмов более одного, запишите любой из них.

Ответ — 21221.

1. 71 нечётное, на 2 не делится — последней была команда 1: 71 − 3 = 68. 2. 68 : 2 = 34 — команда 2. Ветка 68 − 3 = 65 не годится: из 7 за три команды больше 56 не получить. 3. 34 : 2 = 17 — команда 2 (ветка 34 − 3 = 31 тупиковая: из 7 за две команды больше 28 не выйдет). 4. 17 нечётное — команда 1: 14. Затем 14 : 2 = 7 — команда 2.

Записано 1, 2, 2, 1, 2, программа — в обратном порядке: 21221. Проверка: 7 → 14 → 17 → 34 → 68 → 71. Перебор подтверждает, что других программ до пяти команд нет. Это тип задания из демоверсии 2027 года.

Решение на Python
from itertools import product

def run(prog, x):
    for c in prog:
        if c == '1':
            x = x + 3  # прибавь 3
        else:
            x = x * 2  # умножь на 2
    return x

found = []
for n in range(1, 6):  # не более 5 команд
    for prog in product('12', repeat=n):
        if run(prog, 7) == 71:
            found.append(''.join(prog))
print(found)  # все подходящие программы
print(found[0])

Ответ: 21221

Найти неизвестное число b в команде

Пример условия

У исполнителя Гамма две команды:

1. прибавь b
2. умножь на 3

(b — неизвестное натуральное число.) Программа 12112 переводит число 2 в число 93. Определите b.

Ответ — 5.

1. Выполните программу с буквой: 2 + b; затем 3 · (2 + b) = 6 + 3b; дважды прибавить b — 6 + 5b; умножить на 3 — 18 + 15b. 2. Уравнение 18 + 15b = 93, откуда 15b = 75 и b = 5.

Проверка: 2 → 7 → 21 → 26 → 31 → 93. Если неизвестен множитель, проще подставлять b = 2, 3, 4 по очереди.

Решение на Python
good = []
for b in range(1, 101):
    x = 2
    for c in '12112':
        if c == '1':
            x = x + b  # прибавь b
        else:
            x = x * 3  # умножь на 3
    if x == 93:
        good.append(b)
print(good)  # подходящее b одно
print(good[0])

Ответ: 5

Удвоитель: умножь на 2 и вычти 1

Пример условия

У исполнителя Удвоитель две команды:

1. умножь на 2
2. вычти 1

Составьте алгоритм получения из числа 7 числа 51, содержащий не более 5 команд. В ответе запишите только номера команд.

Ответ — 12112.

Здесь удобно считать «цену» вычитания.

1. Сколько удвоений: два дают 28 — мало, четыре дают 112, и чтобы спуститься к 51, вычитаний понадобится больше, чем позволяет лимит. Значит, удвоений три: 7 · 8 = 56. 2. Не хватает 56 − 51 = 5. Вычитание единицы перед двумя последними удвоениями стоит 4, перед одним — 2, в самом конце — 1. Набираем 5 = 4 + 1. 3. Программа: удвоить, вычесть, удвоить, удвоить, вычесть — 12112.

Проверка: 7 → 14 → 13 → 26 → 52 → 51.

Решение на Python
from itertools import product

found = []
for n in range(1, 6):  # не более 5 команд
    for prog in product('12', repeat=n):
        x = 7
        for c in prog:
            x = x * 2 if c == '1' else x - 1
        if x == 51:
            found.append(''.join(prog))
print(found)
print(found[0])

Ответ: 12112

Квадратор: возведение в квадрат

Пример условия

У исполнителя Квадратор две команды:

1. вычти 1
2. возведи в квадрат

Составьте алгоритм получения из числа 3 числа 48, содержащий не более 5 команд. В ответе запишите только номера команд.

Ответ — 21121.

1. 48 не квадрат — последней была команда 1: 48 + 1 = 49. 2. 49 = 72 — команда 2, на экране было 7. 3. 7 и 8 не квадраты — дважды команда 1: 8, затем 9. 4. 9 = 32 — команда 2, пришли к 3.

Записано 1, 2, 1, 1, 2, обратный порядок — 21121. Проверка: 3 → 9 → 8 → 7 → 49 → 48.

Как выполнять задание

  1. Выпишите команды с номерами и обратные к ним: для «умножь на 3» — «раздели на 3», для «прибавь 2» — «вычти 2», для «возведи в квадрат» — «извлеки корень».
  2. Идите от конечного числа к начальному. На каждом шаге отменяйте команду, которая возможна: делить можно только нацело, корень извлекать — только из точного квадрата.
  3. Если возможны обе отмены, проверьте, не уходит ли одна из веток в число, которое из начального за оставшиеся команды уже не получить. Обычно выгоднее деление или корень.
  4. Записывайте номер каждой отменённой команды. Дойдя до начального числа, переверните запись — это и есть программа.
  5. Проверьте прямым ходом: выполните программу от начального числа и сосчитайте команды. В бланк — только цифры, без пробелов и запятых.

Что нужно знать

  • Исполнитель — устройство с фиксированным набором команд; какой номер у какой команды, задаёт условие.
  • Обратный ход: от результата к началу. Умножение и квадрат отменяются не всегда, а сложение и вычитание — всегда, поэтому с конца выбор почти всегда однозначен.
  • «Не более N команд»: программа короче N тоже засчитывается, длиннее — нет.
  • Неизвестное b: выполните программу с буквой вместо числа и решите уравнение. Чем больше b, тем больше результат, поэтому подходящее значение одно.
  • Последовательность команд для исполнителя Робот пишут уже в задании 15, на компьютере и с циклами.

Как оценивается

Проверка по ключу: 1 балл, если ответ записан в той форме, которая указана в инструкции, и полностью совпал с эталоном. Частичного балла нет, черновик не проверяют. Ответ — последовательность цифр: порядок важен, ноль в начале тоже входит в ответ.

Критерии всех заданий экзамена — на странице критериев ОГЭ.

Разбор задания демоверсии 2027

Условие демоверсии 2027 года: «У исполнителя Вычислитель две команды, которым присвоены номера: 1. умножь на 3; 2. прибавь 2. [...] Составьте алгоритм получения из числа 3 числа 37, содержащий не более 5 команд. В ответе запишите только номера команд». Если подходящих алгоритмов несколько, разрешено записать любой.

Обратный ход от 37. 37 на 3 не делится — значит, последней была команда 2: 37 − 2 = 35. 35 тоже не делится — снова 2: 33. Число 33 делится на 3, а вариант 33 − 2 = 31 тупиковый: за две команды из 3 получаются только 5, 7, 9, 11, 15 и 27. Берём команду 1: 33 : 3 = 11. 11 на 3 не делится — команда 2: 9. Наконец 9 : 3 = 3 — команда 1. Записанные номера 2, 2, 1, 2, 1 читаем с конца: 12122. Прямой ход: 3 → 9 → 11 → 33 → 35 → 37, пять команд — совпадает с ключом ФИПИ.

Перебор всех программ из 1–5 команд даёт ровно одну подходящую. Без лимита вариантов больше: 1122222 и 2222122 тоже дают 37, но в них по семь команд. Запись 12122 стоит и в самом условии как пример (там она переводит 2 в 28), но это совпадение: в демоверсии 2026 года пример — 21221, ответ — 11222. Всю демоверсию можно прорешать на странице демоверсия ОГЭ 2027 по информатике.

Типичные ошибки

Не перевернули программу

При обратном ходе номера команд записываются от последней к первой. Если перенести их в бланк как есть, получится другая программа: в демоверсии 2027 года вместо 12122 выйдет 22121, а она переводит 3 в 69.

Перепутали номера команд

Какая команда первая, решает условие, а не привычка. В одном варианте 1 — «умножь», в другом 1 — «прибавь».

Вышли за лимит команд

Программа из семи команд 2222122 тоже переводит 3 в 37, но в демоверсии разрешено не более пяти. Сосчитайте цифры ответа.

Пошли вычитанием там, где нужно деление

Если число делится, обе отмены формально возможны. Вычитание часто уводит в число, до которого из начального уже не дойти за оставшиеся команды. Проверяйте обе ветки.

Записали числа вместо номеров

В ответ идут только номера команд: 12122, а не цепочка 9, 11, 33, 35, 37 и не слова «умножь, прибавь». Пробелы и запятые между цифрами тоже лишние.

Вопросы и ответы

Как решать 5 задание ОГЭ по информатике?

С конца. Возьмите конечное число и на каждом шаге отменяйте последнюю команду: делите, если делится нацело, иначе вычитайте. Номера отменённых команд прочитайте в обратном порядке и проверьте программу прямым ходом от начального числа.

Что значит «если таких алгоритмов более одного, запишите любой»?

Засчитывается любая программа, которая переводит начальное число в конечное и укладывается в лимит команд. Часто подходящая программа всего одна — как в демоверсиях 2026 и 2027 годов, — но искать её «правильный» вариант не нужно.

Можно ли записать программу короче, чем разрешено?

Да. «Не более 5 команд» значит, что четыре, три и даже одна команда тоже подходят, если результат верный. Нельзя превышать лимит.

Можно ли решить задание 5 перебором?

На бланке перебирать все 62 программы из 1–5 команд долго, поэтому используют обратный ход. Дома перебор на Python удобен для самопроверки.

Какие исполнители бывают в задании 5?

Вычислитель с умножением и сложением (демоверсия 2027), Квадратор с возведением в квадрат (демоверсия 2026), Удвоитель с умножением на 2 и вычитанием, а также исполнители с неизвестным числом b в команде.

Другие задания раздела «Алгоритмы и программирование»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ОГЭ по информатике →