Перейти к содержимому

Задание 6 ОГЭ по информатике 2027: исполнение программы

Задание 6до 1 баллаисполнение программы
Раздел
Алгоритмы и программирование · часть 1
Максимальный балл
1 балл
Уровень
базовый
Что проверяет
Формально исполнять алгоритмы, записанные на языке программирования
Что нужно сделать
Выполнить программу с условием для нескольких пар чисел и посчитать запуски, которые напечатали «YES» или «NO», или найти параметр.
Как записать ответ
только число: целое, без единиц измерения и основания системы счисления
Время
Около 4 минут по обобщённому плану ФИПИ
Элемент кодификатора
3.2
Где решается
На бланке, без компьютера: ответ — в бланк № 1
Справляются
48,3 % участников по отчётам Кировской и Иркутской областей и Татарстана за 2025 год

Полстраницы шестого задания ОГЭ по информатике занимает одна и та же короткая программа, записанная пять раз: на алгоритмическом языке, Паскале, Бейсике, Python и C++. По сути важна единственная строка — условие вида «s > 10 или t > A». Программу запускали девять раз с разными парами чисел (s, t), и в ответ нужно дать либо такое целое значение параметра A, чтобы «YES» (или «NO») появилось заданное число раз, либо просто посчитать, сколько раз было напечатано «YES».

Компьютер здесь не нужен: задание из первой части, решение — проверка девяти пар на черновике и аккуратное сравнение чисел, в том числе отрицательных. Сначала отделяют пары, где ответ программы не зависит от A, потом подбирают A для остальных. Так устроено и задание демоверсии 2027 года.

Тренажёр задания 6

Десять заданий номера 6 из банка тренажёра. Ответ проверяется по ключу без регистрации: после проверки — верный ответ и разбор, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 6 вместе с остальными — в вариантах целиком.

Типы задания 6 с решением

Единственное значение A

Пример условия

Программа:

s = int(input())
t = int(input())
A = int(input())
if (s >= 5) or (t < A):
    print("YES")
else:
    print("NO")

Пары (s, t) девяти запусков: (6, 3); (2, 9); (–4, 1); (5, –7); (0, 0); (3, 12); (–8, 6); (4, 2); (8, 15). Укажите целое значение A, при котором программа напечатает «YES» пять раз.

Ответ — 2.

1. Сравнение s >= 5 верно в трёх запусках: (6, 3), (5, –7), (8, 15). Пятёрка проходит, знак нестрогий. 2. Не хватает двух «YES». Значения t в остальных шести парах по возрастанию: 0, 1, 2, 6, 9, 12. 3. t < A должно выполняться ровно для 0 и 1: значит, 1 < A и 2 < A неверно, то есть A = 2.

Проверка: при A = 3 добавится пара (4, 2) и «YES» станет шесть, при A = 1 — четыре. Это тип задания из демоверсии 2027 года.

Решение на Python
# пары (s, t) из условия
pairs = [(6, 3), (2, 9), (-4, 1), (5, -7), (0, 0), (3, 12), (-8, 6), (4, 2), (8, 15)]
good = []
for A in range(-100, 101):
    yes = 0
    for s, t in pairs:
        if (s >= 5) or (t < A):  # программа печатает YES
            yes += 1
    if yes == 5:
        good.append(A)
print(good)  # подходящее A должно быть одно
print(good[0])

Ответ: 2

Наибольшее или наименьшее A

Пример условия

Программа:

s = int(input())
t = int(input())
A = int(input())
if (s > 3) and (t < A):
    print("YES")
else:
    print("NO")

Пары (s, t): (7, –3); (1, 8); (12, 5); (–6, 2); (4, 11); (9, 0); (3, –9); (15, 14); (–2, –5). Укажите наибольшее целое A, при котором программа напечатает «NO» ровно шесть раз.

Ответ — 11.

1. Связка «и»: где s > 3 неверно, всегда «NO». Это (1, 8), (–6, 2), (3, –9), (–2, –5) — четыре «NO»; тройка не больше трёх. 2. Шесть «NO» из девяти — это три «YES». Их дают пары с s > 3, где t < A; значения t по возрастанию: −3, 0, 5, 11, 14. 3. Верно ровно для трёх меньших: 5 < A, но 11 < A неверно, то есть 6 ≤ A ≤ 11.

Наибольшее A — 11, наименьшее было бы 6.

Решение на Python
pairs = [(7, -3), (1, 8), (12, 5), (-6, 2), (4, 11), (9, 0), (3, -9), (15, 14), (-2, -5)]
good = []
for A in range(-100, 101):
    no = 0
    for s, t in pairs:
        if not ((s > 3) and (t < A)):  # программа печатает NO
            no += 1
    if no == 6:
        good.append(A)
print(min(good), max(good))  # границы промежутка
print(max(good))

Ответ: 11

Подсчёт запусков с «YES» или «NO»

Пример условия

Программа:

s = int(input())
t = int(input())
if (s < 4) and (t > -2):
    print("YES")
else:
    print("NO")

Пары (s, t): (3, –1); (–5, 7); (4, 12); (0, –2); (–9, –6); (2, 3); (8, 0); (–1, 15); (3, –4). Сколько раз программа напечатала «NO»?

Ответ — 5.

1. «YES» — когда верны оба сравнения: s < 4 и t > −2. 2. Проверьте каждую пару: (3, –1) — да; (–5, 7) — да; (4, 12) — нет, 4 < 4 ложно; (0, –2) — нет, −2 > −2 ложно; (–9, –6) — нет; (2, 3) — да; (8, 0) — нет; (–1, 15) — да; (3, –4) — нет. 3. «YES» четыре раза, «NO» — 9 − 4 = 5.

Ловушки — границы строгих сравнений и вопрос про «NO» вместо «YES».

Решение на Python
pairs = [(3, -1), (-5, 7), (4, 12), (0, -2), (-9, -6), (2, 3), (8, 0), (-1, 15), (3, -4)]
no = 0
for s, t in pairs:
    if (s < 4) and (t > -2):
        print(s, t, 'YES')
    else:
        print(s, t, 'NO')
        no += 1
print(no)

Ответ: 5

Как выполнять задание

  1. Выпишите условие из удобной вам версии программы и отметьте связку: «или» (or, ||) либо «и» (and, &&). Посмотрите, в каком сравнении стоит A, а в каком — число.
  2. Пройдите по парам и проверьте сравнение без A. При «или» верное сравнение сразу даёт «YES», при «и» неверное сразу даёт «NO» — такие пары от A не зависят.
  3. Посчитайте, сколько ещё «YES» (или «NO») не хватает до числа из вопроса.
  4. Для оставшихся пар выпишите по порядку значения переменной, которая сравнивается с A, и найдите, при каких A сравнение верно ровно для нужного их количества. Строгий знак «>» и нестрогий «>=» дают разные границы.
  5. Если спрашивают «наибольшее» или «наименьшее» A, возьмите край найденного промежутка; если просто «значение», промежуток должен состоять из одного числа. Подставьте ответ и пересчитайте девять запусков.

Что нужно знать

  • «Или» и «и». A или B истинно, когда верно хотя бы одно сравнение; A и B — только когда верны оба. В языках: или / or / OR / ||, и / and / AND / &&.
  • Знаки сравнения. «>» и «<» — строгие: 10 > 10 ложно. «>=» и «<=» пропускают равенство. «Не равно» в Паскале, Бейсике и алгоритмическом языке пишут как «<>», в Python и C++ — как «!=».
  • Отрицательные числа. −12 меньше −11; −3 > −5 верно. Тире в парах условия — обычный минус.
  • Параметр A — целое число. Он один на все девять запусков: вводится вместе с s и t, но одинаков в каждом.

Как оценивается

Проверка по ключу: 1 балл, если ответ записан в той форме, которая указана в инструкции, и полностью совпал с эталоном. Частичного балла нет, черновик не проверяют.

Критерии всех заданий экзамена — на странице критериев ОГЭ.

Разбор задания демоверсии 2027

В демоверсии 2027 года программа печатает «YES», если s > 10 или t > A. Пары: (1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5). Нужно целое A, при котором «YES» напечатано пять раз.

Сравнение s > 10 верно только в двух парах — (11, 2) и (11, 12): там «YES» при любом A. Пары с s = 10 сюда не входят, сравнение строгое. Остаётся добрать три «YES» из семи пар, где решает t > A. Значения t по убыванию: 12, 12, 11, 10, 5, 2, −12. Верным сравнение должно быть ровно для трёх первых: 11 > A, но 10 > A уже нет, то есть A < 11 и A ≥ 10. Подходит одно целое число — 10, это и ключ ФИПИ.

Проверка соседей: при A = 9 к трём «YES» добавится пара (10, 10) — всего шесть; при A = 11 отпадёт (–12, 11) — всего четыре. Перебор всех A от −100 до 100 тоже даёт только 10. Демоверсию целиком можно решить в разделе вариант ОГЭ 2027 по информатике.

Типичные ошибки

Строгое сравнение посчитали как нестрогое

В демоверсии 2027 года пары (10, 10) и (10, 5) легко принять за «YES» по первому сравнению, но 10 > 10 ложно. На каждом числе, равном границе, остановитесь и проверьте знак.

Перепутали «и» с «или»

При «или» хватает одного верного сравнения, при «и» нужны оба. Если смотреть на Бейсик или C++ и не заметить AND вместо OR (&& вместо ||), счёт «YES» получится совсем другим. Выпишите условие отдельно до подсчёта.

Не отделили пары, где A не влияет

Подбирать A сразу по всем девяти парам долго и путано. Сначала найдите запуски, ответ в которых уже решён сравнением без параметра, и вычтите их из нужного числа: останется задача про несколько значений одной переменной.

Ответили на другой вопрос

Спрашивали «NO», а посчитали «YES»; просили наибольшее A, а записали наименьшее; нужно было значение A, а в бланке оказалось число запусков. Перед записью ответа перечитайте последнюю строку условия.

Ошиблись со знаком у отрицательных чисел

−12 меньше −11, а не больше. Чтобы не путаться, расставьте значения переменной на числовой прямой или выпишите их по возрастанию — тогда граница для A видна сразу.

Вопросы и ответы

Как решать 6 задание ОГЭ по информатике с параметром A?

Разбейте пары на две группы: где ответ программы уже ясен без A и где он зависит от A. Посчитайте, сколько «YES» даёт первая группа, и подберите A так, чтобы вторая добавила недостающие.

Какие бывают типы 6 задания?

Три: найти единственное целое A при заданном числе «YES» или «NO»; найти наибольшее или наименьшее такое A; посчитать, сколько раз программа напечатала «YES» или «NO».

Нужно ли знать все пять языков программирования?

Нет. Это одна и та же программа, читайте ту версию, которая привычнее. Достаточно понимать, как в ней записаны «и», «или» и знаки сравнения.

Чем задание 6 в 2027 году отличается от 2026-го?

Только числами и вопросом. В демоверсии 2026 года условие было «s > A или t > 12» и спрашивали наибольшее A, при котором «NO» печатается ровно пять раз. В 2027 году A стоит во втором сравнении, нужно пять «YES», и ответ единственный.

Как проверить ответ программой?

На тренировке скопируйте условие в цикл: перебирайте A от −100 до 100 и для каждого считайте «YES» по всем парам. Если подходящих A несколько, а спрашивают одно значение, — ищите ошибку в выписанном условии.

Другие задания раздела «Алгоритмы и программирование»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ОГЭ по информатике →