Перейти к содержимому

Задание 3 ОГЭ по информатике 2027: истинность высказывания

Задание 3до 1 баллаистинность высказывания
Раздел
Теоретические основы информатики · часть 1
Максимальный балл
1 балл
Уровень
базовый
Что проверяет
Определять истинность составного высказывания
Что нужно сделать
Найти наименьшее или наибольшее число, для которого истинно высказывание с НЕ, И, ИЛИ, или посчитать подходящие числа.
Как записать ответ
только число: целое, без единиц измерения и основания системы счисления
Время
Около 3 минут по обобщённому плану ФИПИ
Элемент кодификатора
2.7
Где решается
На бланке, без компьютера: ответ — в бланк № 1
Справляются
67,6 % участников по отчётам Кировской и Иркутской областей и Татарстана за 2025 год

Третий номер ОГЭ по информатике проверяет одно умение — понять, истинно или ложно составное высказывание. Дано условие про число x: несколько сравнений вроде «x ≥ 6» или «x = 5», связанных словами НЕ, И, ИЛИ и скобками. Часто спрашивают наименьшее натуральное x, при котором всё высказывание ложно. Бывают и вопросы про двузначное или трёхзначное число с условиями на цифры, и подсчёт: для скольких чисел из списка высказывание истинно.

Ответ — одно целое число, его записывают в бланк. Логика здесь школьная, без таблиц истинности на восемь строк: достаточно знать, когда И и ИЛИ дают «ложь», и аккуратно обращаться с границами сравнений. Легко ошибиться на знаке «≥» против «>» и на порядке действий. В демоверсии 2027 года ищут наименьшее x, при котором высказывание ложно.

Тренажёр задания 3

Десять заданий номера 3 из банка тренажёра. Ответ проверяется по ключу без регистрации: после проверки — верный ответ и разбор, а при ошибке — разбор от ИИ. Кнопка «Ещё 5 таких» у типа задания ниже даёт задания одного типа.

Загружаем задание…

Задание 3 вместе с остальными — в вариантах целиком.

Типы задания 3 с решением

Наименьшее x, при котором высказывание ложно

Пример условия

Напишите наименьшее натуральное число x, для которого ложно высказывание:

(НЕ (x < 7) И (x < 10)) ИЛИ (x < 5).

Ответ — 5.

1. Внешняя операция — ИЛИ: высказывание ложно, только если ложны обе части. 2. Снимаем НЕ: НЕ (x < 7) — это x ≥ 7. Первая скобка истинна при x = 7, 8, 9. 3. Вторая часть x < 5 истинна при x = 1, 2, 3, 4. 4. Всё высказывание истинно при 1–4 и 7–9, ложно при 5, 6 и от 10.

Наименьшее ложное — 5. Проверка: «5 ≥ 7» — нет, значит, скобка ложна; «5 < 5» — нет; итог «ложь». При x = 4 вторая часть истинна. Так же решают вопрос про наибольшее x, при котором высказывание истинно: для НЕ (x > 20) И НЕ (x = 20) это 19. Это тип задания из демоверсии 2027 года.

Решение на Python
# перебираем x по возрастанию и ищем первое ложное значение
for x in range(1, 1000):
    if not ((not (x < 7) and (x < 10)) or (x < 5)):
        print(x)
        break

Ответ: 5

Двузначное или трёхзначное число с условием на цифры

Пример условия

Напишите наибольшее двузначное число x, для которого истинно высказывание:

НЕ (число нечётное) И НЕ (сумма цифр больше 12).

Ответ — 92.

1. Переводим на обычный язык: число чётное и сумма его цифр не больше 12. 2. Ищем наибольшее — значит, идём вниз от 99 и берём только чётные: 98, 96, 94, 92… 3. Суммы цифр: 98 — 17, 96 — 15, 94 — 13, 92 — 11.

Первым подходит 92. Проверка: 92 нечётное — нет, сумма 11 больше 12 — нет, обе скобки с НЕ истинны. Для трёхзначных чисел порядок тот же, только начинают с 999 или со 100. Если спрашивают наименьшее, идут вверх от 10.

Решение на Python
# идём от 99 вниз: первое подходящее число и есть наибольшее
for x in range(99, 9, -1):
    digit_sum = x // 10 + x % 10
    if not (x % 2 == 1) and not (digit_sum > 12):
        print(x)
        break

Ответ: 92

Сколько чисел из списка подходят

Пример условия

Дано высказывание:

НЕ (x ≥ 20) И (x > 8).

Для скольких из чисел 4, 25, 9, 20, 13, 8, 19, 31 это высказывание истинно?

Ответ — 3.

1. Снимаем НЕ: x < 20. Вместе с x > 8 получаем промежуток 8 < x < 20. 2. Отбираем числа строго внутри: 9, 13, 19. 3. Границы не входят: 8 не больше 8, а 20 не меньше 20.

Подходят три числа. Список удобно пройти дважды: сначала вычеркнуть всё, что не больше 8, потом всё, что от 20 и выше, и пересчитать оставшееся.

Решение на Python
numbers = [4, 25, 9, 20, 13, 8, 19, 31]
count = 0
for x in numbers:
    if not (x >= 20) and (x > 8):
        count += 1
print(count)

Ответ: 3

Как выполнять задание

  1. Перепишите высказывание на черновик и расставьте порядок действий: сначала скобки, затем НЕ, потом И, последним ИЛИ.
  2. Уберите отрицания: НЕ (x ≥ 6) — это x < 6, НЕ (x = 5) — это x ≠ 5, НЕ (x < 10) — это x ≥ 10. Знак меняется вместе со строгостью.
  3. Решите, что требуется: истинность или ложность. ИЛИ ложно, только когда ложны обе части; И истинно, только когда истинны обе.
  4. Нарисуйте числовую ось и отметьте, где высказывание истинно. Выберите нужное число: наименьшее, наибольшее или посчитайте подходящие из списка.
  5. Подставьте найденное число в исходную запись и проверьте каждую скобку. Проверьте и соседнее число: для него ответ должен получаться другим.

Что нужно знать

  • НЕ меняет значение на противоположное: отрицание «x > 4» — это «x ≤ 4», а не «x < 4».
  • И (конъюнкция) истинно, когда истинны обе части. ИЛИ (дизъюнкция) ложно, когда ложны обе части.
  • Приоритет: скобки, НЕ, И, ИЛИ. Запись «A ИЛИ B И C» читается как «A ИЛИ (B И C)».
  • Натуральные числа начинаются с 1. Двузначные — от 10 до 99, трёхзначные — от 100 до 999.
  • Законы де Моргана: НЕ (A И B) = НЕ A ИЛИ НЕ B; НЕ (A ИЛИ B) = НЕ A И НЕ B.

Как оценивается

Проверка по ключу: 1 балл, если ответ записан в той форме, которая указана в инструкции, и полностью совпал с эталоном. Частичного балла нет, черновик не проверяют.

Критерии всех заданий экзамена — на странице критериев ОГЭ.

Разбор задания демоверсии 2027

Условие демоверсии 2027 года: найти наименьшее натуральное x, при котором ложно (НЕ (x ≥ 6) И НЕ (x = 5)) ИЛИ (x ≤ 7). Внешняя операция — ИЛИ, поэтому ложь нужна в обеих частях сразу.

Вторая часть, x ≤ 7, ложна при x ≥ 8. Первая скобка после снятия отрицаний — x < 6 и x ≠ 5, то есть x от 1 до 4; при x ≥ 8 она тоже ложна. Значит, всё высказывание ложно при x ≥ 8, и наименьшее такое число — 8, ключ ФИПИ. Проверка: при x = 8 первая скобка «8 < 6» — нет, «8 ≤ 7» — нет, итог «ложь»; при x = 7 вторая часть истинна, поэтому 7 не подходит. Перебор на Python по x от 1 до 100 даёт то же: первое ложное значение — 8.

Заметьте, что первая скобка здесь ничего не решает: она истинна только при x ≤ 4, а там и так истинна вторая часть. В демоверсии 2026 года было похожее высказывание (x > 3) ИЛИ НЕ ((x < 4) И (x > 2)), ответ 3. Всю демоверсию можно решить в разделе вариант ОГЭ 2027 по информатике.

Типичные ошибки

Отрицание без смены строгости

НЕ (x ≥ 6) превращают в x ≤ 6 вместо x < 6. Граница переходит в другую часть: число 6 удовлетворяло «x ≥ 6», значит, отрицанию оно уже не подходит. Ответ сдвигается на единицу.

Ложь у ИЛИ ищут в одной части

Для ложности ИЛИ мало, чтобы одна скобка не выполнялась, — должны быть ложны все части. В демоверсии 2027 года так получают 5 или 6: при этих x первая скобка ложна, но вторая, x ≤ 7, ещё истинна.

Нарушили порядок действий

Запись без лишних скобок вычисляют так: сначала НЕ, затем И, потом ИЛИ. Если выполнить ИЛИ раньше И, получится другое высказывание и другой ответ.

Нашли истинное вместо ложного

Вопрос бывает в двух формах: «истинно» и «ложно». Решив задачу верно, легко ответить на соседний вопрос. Перечитайте условие перед тем, как записать число.

Начали перебор с нуля

Натуральные числа начинаются с 1, двузначные — с 10. Ноль или однозначное число в ответе на вопрос о двузначном — неверный ответ, даже если оно подходит по условию.

Вопросы и ответы

Как решать 3 задание ОГЭ по информатике?

Уберите отрицания, превратив их в обычные сравнения, вспомните, когда ложно ИЛИ и когда истинно И, и отметьте подходящие x на числовой оси. Затем выберите нужное число и подставьте его в исходную запись для проверки.

Какие типы задания 3 бывают?

Найти наименьшее или наибольшее натуральное x, при котором высказывание истинно или ложно; найти двузначное или трёхзначное число с условиями на цифры; посчитать, для скольких чисел из списка высказывание истинно.

Нужны ли таблицы истинности?

Обычно нет. В задании одна переменная x, поэтому удобнее числовая ось: отметить промежутки, где выполняется каждая скобка, и соединить их по правилам И и ИЛИ. Таблица истинности пригодится, если запутались в скобках.

Можно ли решить задание 3 перебором?

Да, это надёжный способ проверки. Подставляйте x = 1, 2, 3… и считайте каждую скобку, пока не найдёте первое подходящее число. Часть 1 решают на бланке, поэтому перебор делают в уме или на черновике; перебор на Python удобен для тренировки дома.

Что значит «НЕ (x = 5)»?

Это x ≠ 5: условие истинно для всех чисел, кроме пяти. Такое отрицание почти никогда не сдвигает ответ само по себе, но может вычеркнуть одно число из промежутка.

Другие задания раздела «Теоретические основы информатики»

По демоверсии, спецификации и кодификатору ФИПИ 2027
Обновлено:

Все задания ОГЭ по информатике →